OpenHome Forum
WavSender Timing Error - Printable Version

+- OpenHome Forum (http://forum.openhome.org)
+-- Forum: OpenHome (/forumdisplay.php?fid=1)
+--- Forum: Media (/forumdisplay.php?fid=3)
+--- Thread: WavSender Timing Error (/showthread.php?tid=1577)



WavSender Timing Error - paulw - 09-03-2017 02:26 PM

Hi,
I managed to build ohNet and I am back to trying to pipe(hopefully Songcast one day) linux audio to my Linn DS's.
Experimenting with WavSender gives me :-

"~/openhome/ohSongcast/Posix/Release$ ./WavSender.elf -f recording_09-Mar-17_1252-GMT.wav -n 4c494e4e-0026-0f21-af01-01283516013f
adapter list:
0: 192.168.1.106
using subnet 192.168.1.0
bytes in file: 31637504
sample rate: 44100
sample size: 2
channels: 2
bytes per packet: 880
samples per packet: 220
usec per packet: 4989
adapter=0x55bdd81a9360, iServer=0x55bdd814afc0
q = quit, f = faster, s = slower, n = normal, p = pause, r = restart, m = toggle multicast, e = toggle enabled
Suspicious (implausible) activity in TimerManager. Recent timers are:
Timer: PcmSender (0x7f9a83d15e60)

[Same message repeated - Clipped]

Timer: PcmSender (0x7f9a83d15e60)
Unhandled exception AssertionFailed at OpenHome/Timer.cpp:233 in thread TimerManager


Aborted (core dumped)"

Is there something I can fix my end?


RE: WavSender Timing Error - paulw - 29-05-2017 04:29 PM

Bump

I now get a few seconds of audio and then

Suspicious (implausible) activity in TimerManager. Recent timers are:
Timer: PcmSender (0x7f8408034e60)
Timer: PcmSender (0x7f8408034e60)
[same clipped]
Timer: PcmSender (0x7f8408034e60)
Unhandled exception AssertionFailed at OpenHome/Timer.cpp:233 in thread TimerManager


Aborted (core dumped)