Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ohNet Build Problem
04-03-2017, 12:57 PM
Post: #1
ohNet Build Problem
/Openhome/ohNet$ make
CROSS_COMPILE:
Machine reported by compiler is: x86_64-linux-gnu
Machine reported by uname is: Linux
Building for system Linux and architecture x64
mkdir -p Generated
o Generated/Devices.mak OpenHome/Net/T4/Templates/DvUpnpMakeDevices.tt -a xml:OpenHome/Net/Service/Services.xml
make: o: Command not found
Common.mak:1392: recipe for target 'Generated/Devices.mak' failed
make: [Generated/Devices.mak] Error 127 (ignored)
Attention: a makefile has been re-generated.
mkdir -p Generated
o Generated/Proxies.mak OpenHome/Net/T4/Templates/CpUpnpMakeProxies.tt -a xml:OpenHome/Net/Service/Services.xml
make: o: Command not found
Common.mak:1387: recipe for target 'Generated/Proxies.mak' failed
make: [Generated/Proxies.mak] Error 127 (ignored)
Attention: a makefile has been re-generated.

Then lots of stuff results in:-

~/Openhome/ohNet$ sudo make install
[sudo] password for paulw:
CROSS_COMPILE:
Machine reported by compiler is: x86_64-linux-gnu
Machine reported by uname is: Linux
Building for system Linux and architecture x64
mkdir -p Generated
o Generated/Devices.mak OpenHome/Net/T4/Templates/DvUpnpMakeDevices.tt -a xml:OpenHome/Net/Service/Services.xml
make: o: Command not found
Common.mak:1392: recipe for target 'Generated/Devices.mak' failed
make: [Generated/Devices.mak] Error 127 (ignored)
Attention: a makefile has been re-generated.
mkdir -p Generated
o Generated/Proxies.mak OpenHome/Net/T4/Templates/CpUpnpMakeProxies.tt -a xml:OpenHome/Net/Service/Services.xml
make: o: Command not found
Common.mak:1387: recipe for target 'Generated/Proxies.mak' failed
make: [Generated/Proxies.mak] Error 127 (ignored)
Attention: a makefile has been re-generated.
make: *** No rule to make target 'tt', needed by 'install-pkgconf'. Stop.

Please could you have a look at this.

Thanks
Find all posts by this user


Messages In This Thread
ohNet Build Problem - paulw - 04-03-2017 12:57 PM
RE: ohNet Build Problem - paulw - 07-03-2017, 11:47 PM
RE: ohNet Build Problem - paulw - 30-05-2017, 11:19 AM

Forum Jump: